Notifications
Clear all

[Solved] How do I set "Allow change" for Item's Name Natural Key field?

   RSS

0
Topic starter

I can't find a way to enable the "Allow change" checkbox for an update action on Item, for the Name NK field. See the attached screenshot:

1

I've tried using PLT.InsertOrUpdate, a custom update action in my module, making the action strictly update-only (no allow create), I've played around with the action's type (Standard / Sync), toggled the System of Control checkbox, nothing seems to work.

This is on a 3.2 branch, is it possible a bug on this branch or is there anything else I can check?

Topic Tags
1 Answer
1

Name field on Item model is set to Immutable, i.e. Changes are not allowed to the field. We will need to make it Mutable for "Allow Change" to be editable.

@sean-durkin we should discuss before you try to make it mutable. There are risks involved.

We resolved to update the Item.Name field via direct DB updates, by updating ITEM and inserting an ITEM_ADT record.

© 2020 One Network Enterprises. All rights reserved. Privacy Policy