Notifications
Clear all

[Solved] Why I can't see a PLT model from upper level?

6 Posts
4 Users
1 Reactions
3,661 Views
0
Topic starter

Can't see PipelineInterface model from GLG MPT explorer. But it can be seen from other module like GLGC and TMS.  PipelineInterface is not a private model. Is it a configuration issue? I guess probably a clean build could fix the issue. But  How should I debug this (which folder/file I should check)  if don't do clean build?

Parmod Singh Rana 2022-12-08 05:11:56

@ksun

To include private apis of Platform. Modules need to add below property in "{modulepath}\build.properties" file and re-start the studio to reflect the changes in studio.

#Property
includePrivateApis=true

jcourter 2022-12-08 13:25:00

Hello @ksun - If the above suggestion from Parmod works, let us know and we will mark the response as the answer. In the meantime, I will also look into this.

ksun Topic starter 2022-12-09 21:45:16

includePrivateApis=true already set in GLG\build.properties. So it is not the reason.

Is pipelineInterface Model a private model? I can't see public="true" in the model file, but no public="false" either. I thought if public property is not set, it should be public model (tested when I create a new model through MPT explorer), but looks like system doesn't think so and treat it as private model. Another model is PostalAddress.

Assume pipelineInterface model is a private model, in SCC/model-descriptor.xml, includePrivateAPis=false is set for PLT model. However, I can see pipelineInterface model perfectly in the MPT explorer of SCC. is it a bug? 

This is Neo 3.6.

1 Answer
1

Try removing this element from your head.mpth:

 

image
ksun Topic starter 2022-12-12 22:15:31

@gmerrill This solved the problem. But is it safe to remove SuppressSupplyChainCore tag without changing module functionality? Does removing SuppressSupplyChainCore only affect how MPT explorer works?

Greg Merrill 2022-12-12 22:17:38

Yes @ksun - it is safe. That is an old flag, originally meant to hide certain non-public models from view. In your case, it's fine to add it. It won't cause any other functional implications other than MPT visibility.