Notifications
Clear all

[Solved] Encountering "java.net.ConnectException" when bootstrapping platform_test_suite_Neo3.6

3 Posts
3 Users
1 Reactions
6,661 Views
0
Topic starter

Hi, I've been encountering this issue when trying to bootstrap and building platform_test_suite_Neo3.6.

 

BUILD FAILED

C:\views\INSTAN~1\ib-branches\Neo3.5-rb\build.xml:1259: The following error occurred while executing this line:
C:\views\INSTAN~1\ib-branches\Neo3.5-rb\build.xml:1280: The following error occurred while executing this line:
C:\views\platform_test_suite_Neo3.6\install-staging\build.xml:472: java.net.ConnectException: Connection timed out: connect
at java.base/sun.nio.ch.Net.connect0(Native Method)
at java.base/sun.nio.ch.Net.connect(Net.java:579)
at java.base/sun.nio.ch.Net.connect(Net.java:568)

 

I have tried the following steps but these didn't fix the issue.

  • Deleted all the contents of c:\views\third-party\deps 
  • "Get Latest Revision" of platform_test_suite_Neo3.6
  • Executed ant recreate-local-props, ant-sync, and ant clean build

 

Any other way to resolve this issue?

 

PS. Now, I am also encountering this issue when running "ant build" in my platform_test_suite_Neo35 which doesn't have an issue before.

 

Thank you!

image (6)
1 Answer
1

@alin, please try this

Run Notepad as Administrator (you have to have admin privileges to do this)

File > Open and choose C:\Windows\System32\drivers\etc\hosts ( you may have to choose “All Files” in the file type dropdown to see it for selection in that directory )

Add the following entry, save, and close:

10.6.1.205 repo.onenetwork.com

Run the build again

 

alin Topic starter 2022-03-11 11:54:34

@isingh this solution worked. Thank you so much!

Georgy John 2022-03-16 16:19:08

Inderpal's solution works if you have similar error occurring during bootstrap:

bootstrap error2